« AirVLC Legacy Release

The last version of AirVLC is compatible with the latest versions of OS X. If you want to run AirVLC on OS X 10.6.8 Snow Leopard, use the release below.